Project

General

Profile

Bug #2911

[icecast] SSL doesn't seem to work

ryry - 18 days ago - . Updated 18 days ago.

Status:
unconfirmed
Priority:
bug
Assignee:
-
% Done:

0%


Description

After a new install of Icecast, following the configuration (which I have done previously) to use my lets encrypt certs with icecast, I enable SSL and add the location in paths and (after combining as required) have tried both the certs in their letsencrypt and within the icecast location as many setup docs suggest (which has worked successfully before), however icecast refuses to load the ssl defined port using ssl, instead falling back to plain. On inspection of the logs, it reports that no "SSL capability defined on any port".

Steps to reproduce
Install Icecast.
Change config file to include a combined.pem file containing certificates, enable ssl and open relevant ports.
Start Icecast using systemd.
Try to connect to SSl port etc using browser.

Doesn't seem its a listed bug upstream in arch or beyond, not sure if the version in the repos has openssl in its compilation (or if this was intended?). Or indeed wether I have missed something really obvious? Sorry in advance if this is so.

ryry

History

#1

Updated by freemor 18 days ago

Seems to be a common problem Icecast is finiky about the concatenated cert. see:

https://stackoverflow.com/questions/49300064/icecast-2-and-ssl

#2

Updated by ryry 18 days ago

Thanks for the info freemor, I saw this post when looking to solve issue last week, but for some reason, I don't get any messages about an invalid cert, just the No SSL capability. I tried it several times again, just to be sure I wasn't missing a step in the instructions you suggested, but alas It still fails.

ryry

#3

Updated by freemor 18 days ago

Did you notice right near the bottom where a poster mentiones that the order on concatenation matters. (Just checking).

Also available in: Atom PDF