Bug #3494

[icecat]: sigsegv error on parabola x86-64.

RosieIsHere - 4 months ago - . Updated about 2 months ago.

% Done:



Hi, i got this bug today!

  • expected result:
    Run icecat as normal
  • actual result:
    Fish: Job 1, 'icecat' terminated by signal SIGSEGV (Address boundary error)
  • bit of context:

I was running icecat today like i would, i rebooted my machine, upon reboot i tried launching icecat with keyboard shortcut, it didn't work so i tried to do it from shell where i got the error. I run pacman --debug -Syyuu base but that didn't help. I tried switching kernel to newest libre kernel in repos, didnt work either. I honestly don't know what to do



Updated by bill-auger 4 months ago

  • Subject changed from Icecat sigsegv error on parabola x86-64. to [icecat]: sigsegv error on parabola x86-64.

one very important bit of information you left out, was which version of icecat you are running - the latest version is 102.5.0 but that is not necessarily the one you have installed

$ pacman -Qs icecat

if that is version 60 or 78, you may have some old language-packs installed - in that case, you should uninstall those and upgrade icecat to 102.5.0

$ sudo pacman -R $(pacman -Qsq icecat-l10n) $(pacman -Qsq icecat-addons)
$ sudo pacman -Sy icecat

i can not reproduce this with 102.5.0 - most often, it is some add-on or a language-pack that is crashing - there may be a clue in the logs if you start icecat on the command line - first, i would try running it in safe mode

$ icecat --safe-mode

if there is no problem running in safe mode, it is likely that you could fix the problem by disabling all add-ons and language-packs, then enabling them one by one (restarting the browser each time) until you identify the buggy one - or more simply by deleting your user profile directory

$ rm -rf ~/.mozilla/icecat/

that will reset any customizations you have made though


Updated by bill-auger 4 months ago

just to note, `pacman --debug` is not debugging any application - that is only debugging the package manager

you did not mention which kernel you were using before, nor which you replaced it with - parabola has several "libre kernels" - if the kernel were the problem, you did not give enough information for someone to try reproducing the problem

by "newest", i assume that you meant "the one with the greatest version number" - in the case of software which maintains multiple current versions (such as linux), the one with the greater version number is actually more likely to be buggy, and is not necessarily the "newest" either

if you simply upgraded to a newer version of the same kernel that was already installed (eg: linux-libre), that suggests that your system is not up-to-date, or else you would have already had the newest version of that kernel - as the new bug report template suggests, always run `pacman -Syu` before reporting any bugs; because often, that alone will solve the problem - for some low-level programs such as the kernel, you would also need to reboot afterward, to notice any change

if you would like to try a different kernel, i would suggest linux-libre-lts and linux-libre-vanilla


Updated by bill-auger about 2 months ago

  • Status changed from unconfirmed to not-a-bug

Also available in: Atom PDF