Project

General

Profile

Bug #3553

Gnome-Boxes package has been broken for like 3 years

Chocolat - 4 months ago - . Updated 4 months ago.

Status:
confirmed
Priority:
bug
Assignee:
% Done:

0%


Description

  • steps to reproduce:
    1) # pacman -S gnome-boxes
    2) # select qemu-base, qemu-desktop or qemu-full
  • expected result:
    Install boxes normally
  • actual result:
    can't satisfy the dependency Ā«trackerĀ», needed for gnome-boxes

The last time gnome-boxes was updated was in 2020 so it has been broken since that also is hyper outdated

History

#1

Updated by bill-auger 4 months ago

  • Assignee set to ovruni
  • Status changed from unconfirmed to confirmed

thanks for noticing - i think what happened is that the 'tracker' package was never replaced; so anyone who was using gnome-boxes at the time never saw a problem (including the maintainer, apparently) - only those trying to install it on a system which was installed after 2020 would have noticed; and apparently not enough people want to use it that someone would have reported the bug already

#2

Updated by bill-auger 4 months ago

this will need some significant work - i noticed at least these two problems:

  • hide_download_button.patch does not apply
  • its dep 'libosinfo' needs upgrade; and its mksource() also needs significant re-working

Also available in: Atom PDF