Project

General

Profile

Bug #1636

Can't mount USB drive via PCManFM on LXDE on OpenRC

tatsumaru - over 2 years ago - . Updated 3 months ago.

Status:
open
Priority:
bug
Assignee:
-
% Done:

0%


Description

When I try to open my flash drive via PCManFM by clicking on the icon in the sidebar, I get the following error:

Not authorized to perform operation (polkit authority not available and caller is not uid 0)

I can mount the drive via terminal with sudo mount, but that is not friendly for everyday use.
I have gvfs installed, I tried a ton of polkit settings, but nothing really works.

I am using LXDE with OpenRC.

Thanks.


Files

History

#1

Updated by concatime over 2 years ago

Hi Tatsumaru.
2) sudo groupadd storage
3) sudo usermod -aG storage <user>
1) sudo pacman -Sy gvfs ntfs-3g
4) sudo reboot

#2

Updated by GNUtoo 3 months ago

Today, someone running Parabola x86_64 had the same issue:
  • The error message was slightly different ("operation not supported")
  • Polkit was installed and running
  • Following the commands in this bug fixed it completely

I wonder if we are supposed to fix that (is it supposed to work out of the box, or through the installation of optional dependencies) ? If so where? In the documentation? In packages post-install?

It would also be a good idea to look how other packages handles groups or permissions.

#3

Updated by bill-auger 3 months ago

i dont think this is related to permissions - it is most likely that the gvfs package was the change that makes it work - the openrc guide has a section which mentions the groups that unprivileged users need, 'storage' being one of them - 'gvfs' is an optional dep for pcmanfm; and the automated installers will install gvfs along with the desktop - so there really is no bug here

if anything, this is a documentation bug, in that the install guide does not make it obvious, that openrc has some such caveats, and that people should read the openrc guide before reporting bugs - i just made some changes now, to make that more clear

Also available in: Atom PDF