Project

General

Profile

Freedom Issue #2256

[kmail] Kmail won't run without QT-WebEngine.

PsiGuy60 - almost 5 years ago - . Updated about 1 year ago.

Status:
confirmed
Priority:
bug
Assignee:
-
% Done:

0%


Description

The package will install, but won't actually run, citing a missing QT-WebEngine library if attempting to run from a terminal.

kmail: error while loading shared libraries: libQt5WebEngineCore.so.5

QT-WebEngine was deemed problematic enough to be excluded from the Parabola repositories. Wouldn't it make sense to also remove applications that hard-depend on this library, then?


Related issues

Related to Packages - Freedom Issue #1167: [chromium][electron][qt5-webengine][qt6-webengine] QTWebgine/Electron embeds "entire Chromium platform"confirmed

Actions
Related to Packages - Freedom Issue #2012: KDE depends on Qt5-Webengine (Duh...)confirmed

Actions

History

#1

Updated by PsiGuy60 almost 5 years ago

Seems there's already a pile of other KDE apps in the bug tracker for this exact issue as well.

#2

Updated by freemor almost 5 years ago

  • Related to Freedom Issue #1167: [chromium][electron][qt5-webengine][qt6-webengine] QTWebgine/Electron embeds "entire Chromium platform" added
#3

Updated by bill-auger about 1 year ago

#4

Updated by bill-auger about 1 year ago

  • Status changed from unconfirmed to confirmed
  • Subject changed from [kmail] [qt5-webengine] Kmail won't run without QT-WebEngine. to [kmail] Kmail won't run without QT-WebEngine.
#5

Updated by bill-auger about 1 year ago

  • Description updated (diff)
#6

Updated by bill-auger about 1 year ago

many of them do not hard-code the dependency - they can be made to work without webengine - someone needs to investigate each one, before deciding to fix it or discard it

Also available in: Atom PDF