Project

General

Profile

Bug #2611

OpenRC CLI ISO freezes on boot with AMD ryzen

NewUser69 - 6 months ago - . Updated 6 months ago.

Status:
info needed
Priority:
bug
Category:
LiveISO
Assignee:
% Done:

0%


Description

I have been trying to install this on a pc I recently built. I put in the installation media for the openrc command line version and it constantly froze on boot. I kept rebooting and it never worked. I then inserted an external hard drive that has linux mint installed and it started no problem. I checked to see if it was a problem with the installation media and inserted it into my intel laptop and the installation media started fine. This appears to be a problem that only happens with amd cpus. Specific cpu is the ryzen 3700x. Just freezes during the init process after I select to boot the image in the selection menu at the start of parabola. I hope this is clear. The image below shows the problem but it freezes at different stages during this process.


Files

History

#1

Updated by bill-auger 6 months ago

  • Assignee set to Megver83
  • Subject changed from Installation Media Freezes On Boot (OpenRC command line with amd) to OpenRC CLI ISO freezes on boot with AMD ryzen

that is probably not a problem with the ISO media - it is more likely a kernel issue - i would suggest installing parabola on the external disk, using the computer that can boot the ISO - then see if the ryzen computer can boot parabola from the external disk

#2

Updated by Megver83 6 months ago

  • Status changed from unconfirmed to info needed
  • Category set to LiveISO

Your processor, is this one?

You said you tried Linux Mint and it worked. However, it would help more to try something more Parabola-like.
For instance, did you tried some if these ISOs?:

  • Parabola LXDE with OpenRC
  • Parabola with systemd
  • PureOS/Trisquel/Hyperbola or another free distro
  • Artix
  • Arch Linux

Try them in that same order. If one of them works, then you don't need to test the rest.

#3

Updated by Megver83 6 months ago

I've investigated a bit, and found this:

This is not the result of a deep investigation, just collected some possibly useful info, but looks like it may need non-free firmware. Anyways, try other Parabola ISOs, if not, you could try Trisquel, PureOS or Hyperbola to see if your CPU works with a free distro.

#4

Updated by NewUser69 6 months ago

Tried parabola openrc with lxde. I will try systemd then one of the recommended distros. Won't be home for another 2 hours so I will send what happens when I get home.

Yes, that processor is mine.

*update: can't test until Sunday.

#5

Updated by NewUser69 6 months ago

I have just tested parabola on systemd and it boots just fine.

I don't know if it is a bug with this operating system or just one with openrc in general.

#6

Updated by Megver83 6 months ago

You should then try an older OpenRC ISO https://repo.parabola.nu/iso/ (try one from last year)

If it happens the same, then try Artix to confirm if it's an OpenRC thing

#7

Updated by NewUser69 6 months ago

Just tested an older iso from march of 2019. It froze also. I am now going to test artix linux.

Update: Artix was a success when starting. I believe this concludes the testing but I am available to test if you want me to test more.

Also available in: Atom PDF