Bug #2825

[mesa] upgrade has broken lightdm greeter on armv7 Chromebook

Time4Tea - almost 4 years ago - . Updated over 3 years ago.

% Done:



I am using Parabola on an armv7 Chromebook. I did the following upgrade in pacman earlier today (from pacman.log):

[2020-07-02T12:18:10-0400] [ALPM] transaction started
[2020-07-02T12:18:12-0400] [ALPM] upgraded mesa (20.0.4-1 -> 20.1.2-1)
[2020-07-02T12:18:13-0400] [ALPM] installed mesa-vdpau (20.1.2-1)
[2020-07-02T12:18:13-0400] [ALPM] upgraded libva-mesa-driver (20.0.4-2 -> 20.1.2-1)
[2020-07-02T12:18:14-0400] [ALPM] transaction completed
[2020-07-02T12:18:14-0400] [ALPM] running '30-systemd-update.hook'...

and the upgrade to mesa seems to have broken my lightdm-webkit2-greeter, for some reason. Now when I boot, the greeter just displays a black screen with mouse cursor. However, if I switch to a different VT, I can log in to Mate using startx. Literally all I have done is upgrade mesa and the other 2 packages listed. In /var/log/lightdm/seat0-greeter.log I get the following:

libEGL warning: DRI2: failed to authenticate
libEGL warning: MESA-LOADER: failed to open swrast (search paths /usr/lib/dri)

libEGL warning: MESA-LOADER: failed to open swrast (search paths /usr/lib/dri)

EGLDisplay Initialization failed: EGL_NOT_INITIALIZED
Cannot create EGL sharing context: invalid display (last error: EGL_SUCCESS)

** (lightdm-webkit2-greeter:430): WARNING **: 12:19:10.080: Error running javascript: 

It's obviously pretty annoying, as I would like to be able to keep mesa up-to-date, without breaking the display manager. Any ideas what might be the issue?

I should probably also mention that I have the panfrost driver for the Mali GPU currently disabled.



Updated by Time4Tea over 3 years ago

Hey, I just want to flag that I have resolved this. The issue was that, as well as mesa, I had to also update my llvm-libs. It seemed that package was out of date and was causing some sort of runtime issue with the mesa drivers. I now have mesa 20.1.4 installed and working.

Really, the mesa package should specify the more recent version of llvm-libs as a requirement. But, I guess that's more of an ALARM issue?


Updated by bill-auger over 3 years ago

if both packages are in core, extra, or community, then the upstream
would need to do that - if there was some parabola package which was
causing the version conflict then the parabola package could handle it
- otherwise, a routine `pacman -Syu` should handle it - from that
description, it sounds like `pacman -Syu` was all you needed to do


Updated by Time4Tea over 3 years ago

bill-auger yes, they are both in extra, so seems like an upstream issue. I will submit a bug report to ALARM when I get a chance.

Also available in: Atom PDF