Project

General

Profile

Bug #3410

[retroarch][libretro]: library error: libflac

direnis - about 1 month ago - . Updated about 1 month ago.

Status:
confirmed
Priority:
bug
Assignee:
-
% Done:

0%


Description

  • steps to reproduce:
    1. pacman -S libretro
      $ retroarch
  • expected result:
    Retroarch launchs without any errors
  • actual result:
    retroarch: error while loading shared libraries: libFLAC.so.8: cannot open shared object file: No such file or directory
    

History

#1

Updated by bill-auger about 1 month ago

  • Status changed from unconfirmed to confirmed
  • Description updated (diff)
  • Subject changed from Retroarch library error: libflac to [retroarch][libretro]: library error: libflac
$ lddtree `which retroarch` | grep None
    libFLAC.so.8 => None

$ pkgfile -l flac | grep libFLAC
extra/flac    /usr/lib/libFLAC++.so
extra/flac    /usr/lib/libFLAC++.so.10
extra/flac    /usr/lib/libFLAC++.so.10.0.0
extra/flac    /usr/lib/libFLAC.so
extra/flac    /usr/lib/libFLAC.so.12
extra/flac    /usr/lib/libFLAC.so.12.0.0
extra/flac    /usr/share/aclocal/libFLAC++.m4
extra/flac    /usr/share/aclocal/libFLAC.m4

so probably needs a rebuild

Also available in: Atom PDF