Project

General

Profile

Bug #3546

Unable to update KDE and other q- and -k-things

SolveFinder - 4 months ago - . Updated 4 months ago.

Status:
in progress
Priority:
bug
Assignee:
-
% Done:

100%


Description

Some of kde apps (from libre repository) caused dependency problems.

Here's the error message:

:: installing kparts5 (5.111.0-1) breaks dependency 'kparts' required by ark
:: installing kpty5 (5.111.0-1) breaks dependency 'kpty' required by ark
:: installing kitemmodels5 (5.111.0-1) breaks dependency 'kitemmodels' required by ark
:: installing kitemmodels5 (5.111.0-1) breaks dependency 'kitemmodels' required by kdevelop
:: installing knotifyconfig5 (5.111.0-1) breaks dependency 'knotifyconfig' required by kdevelop
:: installing ktexteditor5 (5.111.0-1) breaks dependency 'ktexteditor' required by kdevelop
:: installing kcmutils5 (5.111.0-1) breaks dependency 'kcmutils' required by kdevelop
:: installing threadweaver5 (5.111.0-1) breaks dependency 'threadweaver' required by kdevelop
:: installing kded5 (5.111.0-1) breaks dependency 'kded5=5.110.0' required by kio5
:: installing kdeclarative5 (5.111.0-1) breaks dependency 'kdeclarative' required by libksysguard
:: installing knewstuff5 (5.111.0-1) breaks dependency 'knewstuff' required by libksysguard
:: installing kpty5 (5.111.0-1) breaks dependency 'kpty' required by okular
:: installing kactivities5 (5.111.0-1) breaks dependency 'kactivities' required by okular
:: installing threadweaver5 (5.111.0-1) breaks dependency 'threadweaver' required by okular
:: installing kparts5 (5.111.0-1) breaks dependency 'kparts' required by okular
:: installing purpose5 (5.111.0-1) breaks dependency 'purpose' required by okular

These packages (at least) require an update according to upstream build recipe:
  • libksysguard
  • okular
  • ark
  • kdevelop

Subtasks

Bug #3547: Upgrade error: installing sonnet5 (5.111.0-1) breaks dependency 'sonnet' required by quassel-client-qtfixed

Actions
Bug #3552: [quassel-client-small] Requires Rebuild Against New Sonnet Versionduplicate

Actions

History

#1

Updated by bill-auger 4 months ago

  • Status changed from unconfirmed to confirmed
#2

Updated by bill-auger 4 months ago

  • Subject changed from Unable to update KDE due to unresolveable dependencies to Unable to update KDE and other q- and -k-things

this general issue affects many (perhaps most) q- and -k-things and their dependents - many packages will need to be rebuilt - im determining the full extent now

#3

Updated by bill-auger 4 months ago

these are the packages which need to be rebuilt or dropped:

pkgbase armv7h x86_64
libre/ark DONE DONE
libre/audex
libre/kde-development-environment-meta
libre/kdevelop DONE
libre/kile DONE
libre/kopete
libre/libksysguard DONE DONE
libre/marble
libre/nextcloud-client DONE
libre/okular DONE
libre/parley
libre/qtcreator
libre/quassel DONE DONE
libre/ktorrent DONE DONE
nonprism/choqok
nonprism/kio5 DONE DONE
nonprism/kopete
pcr/dolphin-root
pcr/kate-root
pcr-testing/calamares
#4

Updated by bill-auger 4 months ago

  • Status changed from confirmed to in progress

Also available in: Atom PDF