Project

General

Profile

Problem updating the new installation from parabola-x86_64-systemd-lxde-2019.06-pre-complete.iso

AdamHoles - 6 days ago -

I can't update the new installation from https://mirror.grapentin.org/parabola/iso/x86_64-systemd-lxde-2019.06-pre/parabola-x86_64-systemd-lxde-2019.06-pre-complete.iso .
My pacman version is:

$ LC_ALL=en_GB.UTF-8 pacman --version

 .--.                  Pacman v5.2.2 - libalpm v12.0.2
/ _.-' .-.  .-.  .-.   Copyright (C) 2006-2020 Pacman Development Team
\  '-. '-'  '-'  '-'   Copyright (C) 2002-2006 Judd Vinet
 '--'
                       This program may be freely redistributed under
                       the terms of the GNU General Public License.


I can't update libarchive:
$ LC_ALL=en_GB.UTF-8 sudo pacman -S libarchive
resolving dependencies...
looking for conflicting packages...

Packages (2) acl-2.2.53-3  libarchive-3.4.3-1

Total Download Size:   0.63 MiB
Total Installed Size:  1.40 MiB
Net Upgrade Size:      0.03 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 acl-2.2.53-3-x86_64                                                                                               136.6 KiB   663 KiB/s 00:00 [#######################################################################################] 100%
 libarchive-3.4.3-1-x86_64                                                                                         505.1 KiB  1191 KiB/s 00:00 [#######################################################################################] 100%
(2/2) checking keys in keyring                                                                                                                 [#######################################################################################] 100%
downloading required keys...
:: Import PGP key 6D42BDD116E0068F, "Christian Hesse <arch@eworm.de>"? [Y/n] y
(2/2) checking package integrity                                                                                                               [#######################################################################################] 100%
error: acl: key "0429897DE5F3BDAC537A30696D42BDD116E0068F" is unknown
:: Import PGP key 0429897DE5F3BDAC537A30696D42BDD116E0068F? [Y/n] y
error: key "0429897DE5F3BDAC537A30696D42BDD116E0068F" could not be looked up remotely
:: File /var/cache/pacman/pkg/acl-2.2.53-3-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: libarchive: key "0429897DE5F3BDAC537A30696D42BDD116E0068F" is unknown
:: Import PGP key 0429897DE5F3BDAC537A30696D42BDD116E0068F? [Y/n] y
error: key "0429897DE5F3BDAC537A30696D42BDD116E0068F" could not be looked up remotely
:: File /var/cache/pacman/pkg/libarchive-3.4.3-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.


Replies (2)

Problem updating the new installation from parabola-x86_64-systemd-lxde-2019.06-pre-complete.iso - bill-auger - 5 days ago -

you probably need to install the latest keyrings before
installing any packages to the live system

  1. pacman -Sy archlinux-keyring parabola-keyring

RE: Problem updating the new installation from parabola-x86_64-systemd-lxde-2019.06-pre-complete.iso - AdamHoles - 5 days ago -

This isn't the live system, I've already installed Parabola GNU/Linux-libre from the live system to the hard disk drive (HDD).
I can't install the latest keyrings.

adam@holes-pc: ~
$ LC_ALL=en_GB.UTF-8 sudo pacman -Sy archlinux-keyring parabola-keyring
[sudo] password for adam: 
:: Synchronizing package databases...
 libre is up to date
 core is up to date
 extra is up to date
 community is up to date
 pcr is up to date
resolving dependencies...
looking for conflicting packages...

Packages (2) archlinux-keyring-20201028-1  parabola-keyring-20201109-1

Total Download Size:   0.92 MiB
Total Installed Size:  1.42 MiB
Net Upgrade Size:      0.36 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 archlinux-keyring-20201028-1-any                                                                                  941.3 KiB  1384 KiB/s 00:01 [#######################################################################################] 100%
(2/2) checking keys in keyring                                                                                                                 [#######################################################################################] 100%
downloading required keys...
:: Import PGP key 6D42BDD116E0068F, "Christian Hesse <arch@eworm.de>"? [Y/n] y
(2/2) checking package integrity                                                                                                               [#######################################################################################] 100%
error: archlinux-keyring: key "0429897DE5F3BDAC537A30696D42BDD116E0068F" is unknown
:: Import PGP key 0429897DE5F3BDAC537A30696D42BDD116E0068F? [Y/n] y
error: key "0429897DE5F3BDAC537A30696D42BDD116E0068F" could not be looked up remotely
:: File /var/cache/pacman/pkg/archlinux-keyring-20201028-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
adam@holes-pc: ~
$ 

    (1-2/2)