Project

General

Profile

Bug #1665

[networkmanager-elogind]: error while loading shared libraries: libpsl.so.5

arojas0609 - over 2 years ago - . Updated about 2 years ago.

Status:
open
Priority:
broken
Assignee:
% Done:

100%


Description

[networkmanager]: error while loading shared libraries: libpsl.so.5: cannot open shared object file: No such file or directory.

Package ==> networkmanager-elogind

Parabola OpenRC version.


Related issues

Related to Packages - Bug #1683: [libpsl]: pacman Update problem 'libpsl.so.6'open2018-03-28

Actions

History

#1

Updated by arojas0609 over 2 years ago

So far I've found a solution, I don't know if is this correct, I have uninstall networkmanager-elogind and install networkmanager-1.10.6-1.

#2

Updated by bill-auger over 2 years ago

the fix for now is to add a symlink manually and then reboot

$ cd /usr/lib/
$ sudo ln -s libpsl.so.6 libpsl.so.5
#3

Updated by bill-auger over 2 years ago

  • Description updated (diff)
#4

Updated by bill-auger over 2 years ago

  • Related to Bug #1683: [libpsl]: pacman Update problem 'libpsl.so.6' added
#5

Updated by bill-auger over 2 years ago

  • Priority changed from bug to broken
  • Subject changed from NetworkManager: error while loading shared libraries: libpsl.so.5 to [networkmanager-elogind]: error while loading shared libraries: libpsl.so.5

libremakepkg fails to build 'networkmanager-elogind' v1.10.6 - same package conflict for i686 and x86_64

the updated PKGBUILD for v1.10.6 is in abslibre.git

$ sudo libremakepkg
....
 |  looking for conflicting packages...
 |  :: dbus-elogind and dbus are in conflict (libdbus). Remove dbus? [y/N] error: unresolvable package conflicts detected
 |  error: failed to prepare transaction (conflicting dependencies)
 |  
 |  :: dbus-elogind and dbus are in conflict
 |  ==> ERROR: 'pacman' failed to install missing dependencies.
....
#6

Updated by bill-auger over 2 years ago

  • Assignee set to Megver83

Also available in: Atom PDF