Project

General

Profile

Bug #2145

[texlive-bin][cups-filters] installing poppler (0.73.0-1) breaks dependency 'poppler=0.72.0-1'

Rigo-V - 3 months ago - . Updated about 2 months ago.

Status:
fixed
Priority:
bug
Assignee:
% Done:

0%


Description

Can't update the system with pacman -Syu:

:: installing poppler (0.73.0-1) breaks dependency 'poppler=0.72.0-1' required by texlive-bin


Related issues

Related to Packages - Bug #2173: [texlive-bin] [poppler] installing poppler (0.74.0-1) breaks dependency 'poppler=0.73.0-1' required by texlive-binfixed

Actions
Related to Packages - Bug #2207: [i686] rebuild [texlive-bin][cups-filters] to use latest popplerduplicate

Actions

History

#1

Updated by GNUtoo 3 months ago

Fixed on i686 and x86_64, waiting for arm to build

#2

Updated by GNUtoo 3 months ago

The arm build is failing with:

 |  ==> Creating source package...
 |    -> Adding PKGBUILD...
 |    -> Generating .SRCINFO file...
 |    -> Adding texlive-source...
 |    -> Adding pdftex-poppler0.72.patch...
 |    -> Adding luatex-poppler-fixes.patch...
 |    -> Adding xetex-poppler-fixes.patch...
 |    -> Adding freetype-pkgconfig.patch...
 |    -> Adding synctex-missing-header.patch...
 |    -> Compressing source package...
 |
 |  gzip: stdout: No space left on device
 |  bsdtar: Write error
 |  ==> ERROR: Failed to create source package file.
 |  ==> ERROR: Could not download sources.

While I do have space on /:

Size  Used Avail Use% Mounted on
25G   12G   13G  49% /

#3

Updated by GNUtoo 3 months ago

  • Subject changed from [texlive-bin] installing poppler (0.73.0-1) breaks dependency 'poppler=0.72.0-1' to [texlive-bin][armv7h] installing poppler (0.73.0-1) breaks dependency 'poppler=0.72.0-1'
#4

Updated by bill-auger 3 months ago

perhaps that gzip command is exploding into /tmp - maybe that is where you have insufficient space

#5

Updated by bill-auger about 2 months ago

  • Related to Bug #2173: [texlive-bin] [poppler] installing poppler (0.74.0-1) breaks dependency 'poppler=0.73.0-1' required by texlive-bin added
#6

Updated by bill-auger about 2 months ago

  • Related to Bug #2207: [i686] rebuild [texlive-bin][cups-filters] to use latest poppler added
#7

Updated by bill-auger about 2 months ago

  • Assignee set to GNUtoo

GNUtoo -

this is still broken for i686 - someone just reported a duplicate Bug #2207

# pacman -Sy texlive-bin cups-filters
:: Synchronizing package databases...
 libre-testing is up to date
 build-support is up to date
 staging is up to date
 libre is up to date
 core is up to date
 extra is up to date
 community is up to date
 pcr is up to date
resolving dependencies...
:: The following packages cannot be upgraded due to unresolvable dependencies:
      texlive-bin  cups-filters

:: Do you want to skip the above packages for this upgrade? [y/N] 
:: unable to satisfy dependency 'poppler=0.72.0-1.0' required by texlive-bin
:: unable to satisfy dependency 'poppler=0.72.0' required by cups-filters

also, poppler 0.74 for i686 is in [staging] now so we will want to watch this one

#8

Updated by bill-auger about 2 months ago

  • Subject changed from [texlive-bin][armv7h] installing poppler (0.73.0-1) breaks dependency 'poppler=0.72.0-1' to [texlive-bin][cups-filters] installing poppler (0.73.0-1) breaks dependency 'poppler=0.72.0-1'
#9

Updated by GNUtoo about 2 months ago

  • Status changed from open to fixed

It should be fixed again on i686 now.

Reopen the bug if it breaks again or if it's not fixed for you.

Also available in: Atom PDF