Project

General

Profile

Bug #2659

lib32-dbus and dbus are conflicting (nonsystemd)

Time4Tea - about 1 year ago - . Updated 14 days ago.

Status:
in progress
Priority:
bug
Assignee:
% Done:

0%


Description

Hi, I just tried to install lib32-libdbus (x86) and got the following error:

looking for conflicting packages...
:: lib32-dbus and dbus are in conflict (libdbus-1.so). Remove dbus? [y/N] 
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: lib32-dbus and dbus are in conflict

Something must be wrong here, as dbus is listed as a dependency of lib32-dbus. I have the nonsystemd version of dbus installed.

History

#1

Updated by Time4Tea about 1 year ago

Sorry, I meant lib32-dbus. Doesn't look like I can edit the original post.

#2

Updated by Megver83 about 1 year ago

It's likely you do not have [nonsystemd-multilib] enabled or above [multilib] in pacman.conf, which avoids you from installing nonsystemd-multilib/lib32-dbus instead of multilib/lib32-dbus

#3

Updated by Time4Tea about 1 year ago

Megver83 yes, that worked. Thanks!

#4

Updated by bill-auger about 1 year ago

  • Assignee set to Megver83
  • Status changed from unconfirmed to in progress
#5

Updated by Time4Tea 14 days ago

Hi, FYI: this seems to be happening again. I am seeing the same problem with lib32-dbus conflicting with dbus, even though I have [nonsystemd-multilib] above [multilib] in my pacman.conf. Possibly because the lib32-dbus package in [nonsystemd-multilib] is behind the version in [multilib], so it is trying to install the [multilib] one?

Also available in: Atom PDF