Bug #2958

[libre/icedove-extension-enigmail] Not compatible with latest [gnupg]

infertux - about 2 years ago - . Updated almost 2 years ago.

in progress
% Done:



installing gnupg (2.2.25-1) breaks dependency 'gnupg<2.2.25' required by icedove-extension-enigmail

See also

Related issues

Related to Packages - Bug #3034: icedove: XPCOMGlueLoad error for file /usr/lib/icedove/libxul.sounconfirmed




Updated by and_who about 2 years ago

Tried upgrading again today and got this, so still an issue:

error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'gnupg<2.2.25' required by icedove-extension-enigmail

Updated by infertux about 2 years ago

Yes I'm still having this issue as well. This package breaks every time gnupg gets an update. I wonder if we could make the dependency constraint more flexible using sematic versioning, e.g. 'gnupg>=2.2,gnupg<2.3'?


Updated by and_who about 2 years ago

Are there any plans towards phasing this out by just using a newer Thunderbird which includes PGP support? Enigmail had a 2.2.x release where it helped import keys into the new built-in system so if you have both installed it would phase out this package.


Updated by eliotime3000 about 2 years ago

So far, Icedove is in process to merge to the version 78.x.0 and there's no intention to update the email client to the actual version (78.7.0).

Anyway... I hope that Icedove would be updated to the version 78.7.0 with the Enigmail merging package that is present in Arch.


Updated by bill-auger almost 2 years ago

  • Assignee set to oaken-source
  • Status changed from unconfirmed to in progress

icedove-78.9.1 is now in [libre-testing], if people want to test it out


Updated by bill-auger over 1 year ago

  • Related to Bug #3034: icedove: XPCOMGlueLoad error for file /usr/lib/icedove/ added

Also available in: Atom PDF