Project

General

Profile

Bug #3157

Bug #3155: [hwids][hwdata]: package renamed - dependents require rebuild

[eudev] depends on hwids, which has been replaced by hwdata

kabo - 9 months ago - . Updated 8 months ago.

Status:
fixed
Priority:
bug
Assignee:
% Done:

0%


Description

  • steps to reproduce:
    1) run pacman -Syu
    2) see prompt :: Replace hwids with core/hwdata? [Y/n] y
  • expected result:
    hwids to be replaced by hwdata
  • actual result:
    error: failed to prepare transaction (could not satisfy dependencies)
    :: removing hwids breaks dependency 'hwids' required by eudev

I presume eudev needs to be updated to depend on hwdata rather than hwids?


Related issues

Related to Documentation - Housekeeping #3168: [eudev-systemd]: package dropped - still suggested on the wikiopen

Actions

History

#1

Updated by bill-auger 9 months ago

  • Parent task set to #3155
  • Assignee set to Megver83
  • Status changed from unconfirmed to in progress

megver maintains this package - the conflict is resolved now

#2

Updated by bill-auger 9 months ago

  • Assignee changed from Megver83 to bill-auger
#3

Updated by bill-auger 9 months ago

  • Status changed from in progress to fixed
#4

Updated by kabo 9 months ago

Cool, thanks for that. I think the installation guide needs to be updated as well, it says to use eudev by default?

https://wiki.parabola.nu/Installation_Guide

#5

Updated by bill-auger 8 months ago

  • Assignee changed from bill-auger to Megver83
#6

Updated by bill-auger 8 months ago

  • Related to Housekeeping #3168: [eudev-systemd]: package dropped - still suggested on the wiki added

Also available in: Atom PDF