Project

General

Profile

anki without qt5-webengine

nona - 3 months ago -

Hello,

I would like to install anki (which is available in the repos), but it requires qt5-webengine

    resolving dependencies...
    warning: cannot resolve "qt5-webengine", a dependency of "anki" 
    warning: cannot resolve "python-pyqtwebengine", a dependency of "anki" 
    :: The following package cannot be upgraded due to unresolvable dependencies:
          anki

I have seen other packages which go around such dependencies. How to do it with this? Thanks.


Replies (3)

RE: anki without qt5-webengine - theova - 3 months ago -

Hi,

Thank you for the notification. Before posting a new issue, please have a look at the bug tracker and search for the package name.

There is already an open issue: #1426

nona wrote:

How to do it with this?

One would need to patch the code and modify the program s.t. it doesn't depend on qt5-webengine anymore. However this might not be an easy task.
If you are interested in building libre packages, you can find additional informations here.

RE: anki without qt5-webengine - nona - 3 months ago -

Sorry, I should have searched before, I usually do.

I assume that s.t. = so that

Yes, I am interested. I don't know if I have the drive to modify anki's source to use webkit, but I'll send an e-mail to the developers... who knows, may be they'll do it!

RE: anki without qt5-webengine - nona - about 1 month ago -

Good news! I helped towards the liberation of software (for the first time? dunno)
https://anki.tenderapp.com/discussions/ankidesktop/37764-webkit
I attach a PKGBUILD.

This uses lovac42's repository for an Anki alternative called CCBC. Damien Elmes (who I assume is a developer of Anki) seems to be very keen on not migrating.

    (1-3/3)