Project

General

Profile

Setting up Parabola on CuBox-i4Pro

ryry - about 1 month ago -

Hi
I am currently trying to get parabola working on a CuBox-i4Pro. I used the armv7h tarball and flashed the relevant, but outdated version of u-boot for the cubox-i variants. However, it fails to boot, i used the built in serial console and minicom to see what was happening.

The following is displayed;

U-Boot SPL 2013.10-rc4 (Mar 02 2016 - 07:03:28)
Boot Device: SD1
spl: error reading image u-boot.img, err - -1
Load image from RAW...
spl: wrong MMC boot mode
  1. ERROR ### Please RESET the board ###

The /boot folder on the card now has both SPL and u-boot.img in it only. Now, I think it is looking on the wrong boot device, but not sure. Looking at the archlinux tarball, they seem to have the dtbs sub directory and its contents along with a zlinuz image and the boot.scr and uEnv.txt files in the /boot directory.

Does anyone have any ideas to try or knowledge on how to get it working. I wondered if it was the older version of u-boot, but again just a guess.

Thanks

ryry


Replies (4)

RE: Setting up Parabola on CuBox-i4Pro - bill-auger - 9 days ago -

it does not mean that u-boot is outdated - these ROMs usually do not need to be changed - the u-boot ROM is often as old as the hardware design is - rather than "outdated", the more accurate description may be, that these are a different class of device, which parabola does not have a u-boot ROM for

the best (simple) reference guide we have, for which ARM boards may support a 100% libre distro, is the freedombox wiki - that lists the following cubie models:

from https://wiki.debian.org/FreedomBox/Hardware/:
  • Cubieboard2
  • Cubieboard2-Dual
  • Cubieboard3/Cubietruck

those are all designated as armhf/sunxi supported devices - so in theory, parabola could support those - it is just not obvious that "CuBox-i4Pro" or "cubox-i variants" are in that same class as the u-boot ROM you are trying to install

note that on the freedombox wiki page, we are only interested in the first list, not the ones listed as "the hardware can't run entirely on free software" - you may notice a correspondence between those marked as "OSWH", and the "Parabola recommended computers, with priority support" https://wiki.parabola.nu/Computers - it is a coincidence; but not much of one - "OSWH" computers are more likely to have generic support, already in u-boot and linux-libre

support for all of these "exotic" computers is a continuing work-in-progress - if yours can be made to run pure parabola, and if one of the parabola devs acquires one, it could also be recommended with priority support - for now, people will need to experiment and cooperate with parabola to get other SBCs working - it may only take some investigation/experiments and possibly to add a new u-boot ROM for parabola - the first step would be to identify the CPU model

RE: Setting up Parabola on CuBox-i4Pro - ryry - 9 days ago -

Thanks for the response, I managed after some playing around a while back to flash the parabola repo's version of uboot-cubox-i which covered the cubox-i4, it turned out that the 2013 version required an extra flash at a different sector, this can be seen here on arch arm (though they now use 2017's version) https://archlinuxarm.org/packages/armv7h/uboot-cubox-i/log?id=36e12c2985b1a1eca00b677b93120c16d92252ae

I also had to play around with the uEnv.txt which needed the removal of the compress and image type flags and both that the dtb and the initial images needed to go in outside the main /boot folder as I could never get the boot.scr to look in the /boot folder. I tried with the tarball release for amv7h, but couldn't get past updating the archlinux32 keyring, even trying the usual reinstall the other key-rings and update etc.

Then I tried an pacstraping with (cross architecture), but for some reason, once booted to login, some systemd units where stuck activating, such as dbus and logind and I couldn't think where to go from here.

But the uboot issue was by and large resolved and its interesting as you say that the uboot roms don't need to be changed, I didn't know that was the case, but I guess that makes sense as I suppose its analogous to x86 bios which for some are never upgraded and the computers boot fine.

Many thanks

Ryan

RE: Setting up Parabola on CuBox-i4Pro - bill-auger - 9 days ago -

the archlinux32 keyring problem will be solved with the next pacman - for now, you can get past one of two ways

appending to pacman or pacstrap commands: --assume-installed=archlinux32-keyring

or if that does not work:

# pacman -Sy parabola-keyring
# pacman -U https://repo.parabola.nu/pool/parabola/archlinux32-keyring-20220209-1.0.parabola2-any.pkg.tar.zst
# pacman -S archlinux-keyring

from the host system, you would have problems configuring systemd or generating the initcpio - you may need to chroot in for those tasks, after the packages are installed

# arch-chroot /mnt

RE: Setting up Parabola on CuBox-i4Pro - ryry - 7 days ago -

Thanks for the response and extra info bill-auger, I managed to use the tarball and arch-chroot functionality to upgrade the keyring and build the boot images need and then a full system upgrade, after removing the entries in the fstab, it boots perfectly and without issue. :) I will now see how it peforms once I have graphic environment etc. Thank you once again.

ry

    (1-4/4)