Project

General

Profile

Problem with cups and poppler after upgrade

egils - 12 months ago -

$ pacman -Qi poppler
Namn : poppler
Version : 20.12.1-1
Beskrivning : PDF rendering library based on xpdf 3.0
Arkitektur : x86_64
Webbadress : https://poppler.freedesktop.org/
Licens : GPL
Tillhör grupperna : Ingen
Tillhandahåller : libpoppler.so=105-64 libpoppler-cpp.so=0-64
Beror av : libjpeg gcc-libs cairo fontconfig openjpeg2 lcms2 nss curl
Valfria beroenden : poppler-data: encoding data to display PDF documents containing CJK characters[installerat]
Beroende för : gdal libreoffice-still pdfgrep
Valfritt beroende för : recoll
Krockar med : poppler-qt3<20.12.1 poppler-qt4<20.12.1
Ersätter : Ingen
Storlek som installerad : 5,63 MiB
Förpackare : Andreas Radke <>
Kompileringsdatum : mån 7 dec 2020 16:56:32
Installerades : tis 8 dec 2020 09:09:31
Orsak : Installerat som beroende för ett annat paket
Installationsskript : Nej
Validerat av : Signatur

egil@parabola:~$ LANG=en_US.utf8 sudo pacman -Syyy cups
... updating repos ...
resolving dependencies...
warning: cannot resolve "poppler<20.12.1", a dependency of "cups-filters"
warning: cannot resolve "cups-filters", a dependency of "cups"
:: The following package cannot be upgraded due to unresolvable dependencies:
cups

:: Do you want to skip the above package for this upgrade? [y/N]

Upgraded today, seems there is a problem on cups-filters and cups related to the new poppler version.


Replies (3)

RE: Problem with cups and poppler after upgrade - oaken-source - 12 months ago -

thanks for pointing this out. the problem has been fixed in the latest version of cups-filters.

RE: Problem with cups and poppler after upgrade - bill-auger - 12 months ago -

to be clear about the version constraints, that is not itself a
bug - we add these specifically to avoid a common bug, whereby
some parabola package would become broken by an upgraded arch
package

the version constraint allows the program to continue functioning
as expected, rather than becoming broken routinely; and the
pacman error serves as a warning, that the package needs to be
rebuilt

anytime that pacman gives an error message, it is almost always
worthy of a bug report - in the case of 'poppler' and 'icu'
dependents, the bug reports are a matter of routine; and there
are permanent tickets for tracking them

https://labs.parabola.nu/issues/2546

    (1-3/3)