Project

General

Profile

Housekeeping #2546

[STICKY][poppler]: and friends (x86_64)

Anonymous - almost 2 years ago - . Updated 17 days ago.

Status:
open
Priority:
bug
Assignee:
-
% Done:

100%


Description

this is the current list of 'poppler' dependents for x86_64 systems - each time 'poppler is upgraded in arch, each of these packages should be rebuilt against the upgraded 'poppler' with the sodeps for each 'libpoppler*.so', then the 'poppler-parabola' package should be upgraded to the same version as arch

the list is of course subject to change - the attached files can be used to generate the current list


Subtasks

Housekeeping #2351: [libre/cups-filters]: rebuild against new poppler (x86_64)fixedbill-auger

Actions
Housekeeping #2776: [libre/texlive-bin]: rebuild against new poppler (x86_64)fixedbill-auger

Actions

Related issues

Related to Packages - Bug #3075: [cups-filters][texlive-bin]: installing poppler (N) breaks dependencyduplicate

Actions

History

#1

Updated by freemor almost 2 years ago

  • % Done changed from 0 to 20
  • Status changed from unconfirmed to confirmed
  • Subject changed from testing/[icu][poppler] Conflicts to [icu 0.65.1][poppler 0.82.0] Conflicts - packages need rebuilds

[libre/hardinfo] - Rebuild for x86_46
[libre/cups-filters] - Rebuilt for x86_64
[libre/texlive-bin] - uilding now for x86_64

The new poppler nad icu haven't hit for the other 2 Architectures yet.

#2

Updated by freemor almost 2 years ago

[libre/texlive-bin] Rebuilt for x86_64

Starting [libre/iceape]

#3

Updated by freemor almost 2 years ago

IceApe failed first rebuild trying again... going to bed now will check it in the morning

#4

Updated by freemor almost 2 years ago

[libre/iceape] not rebuilding easily.. switching to iceweasel as that is more popular and should probably get done first.
I'm expecting it to fail. These Moz browsers never just rebuild easily.

#5

Updated by freemor almost 2 years ago

Hmmm.. [libre/iceweasel] seems to be missing the '0001-Use-remoting-name-for-GDK-application-names.patch' file.
Trying icecat

#6

Updated by freemor almost 2 years ago

Ok, 12 minutes in on the Icecat rebuild.. Here's hoping it finishes.

#7

Updated by freemor almost 2 years ago

Nope.. it crapped out while i was writing the above.

#8

Updated by freemor almost 2 years ago

If Other Dev want to take a look at the build logs they are in:

/mnt/data/freemor_builds/

On beefcake

Gotta run IRL Calling

#9

Updated by freemor almost 2 years ago

Another Try at rebuilding Icecat...

#10

Updated by freemor almost 2 years ago

Looks like all the Browser builds are failing with very similar errors.
I'm guessing something has changed in the build environment that they don't like

From most recent Icecat attempt

 |  21:09.22 libnetwerk_base.a.desc
 |  21:09.68 make[2]: *** [/build/icecat/src/icecat-60.3.0/config/recurse.mk:33: compile] Error 2
 |  21:09.68 make[1]: *** [/build/icecat/src/icecat-60.3.0/config/rules.mk:434: default] Error 2
 |  21:09.68 make: *** [client.mk:168: build] Error 2
 |  21:09.69 180 compiler warnings present.
 |  ==> ERROR: A failure occurred in build().
 |      Aborting...
==> Copying log and package files out of the chroot...

Off to investigate

#11

Updated by freemor almost 2 years ago

Found the missing 0001-Use-remoting-name-for-GDK-application-names.patch

Retrying [libre\iceweasel]

#12

Updated by freemor almost 2 years ago

Well, crap:

 1:05.15 checking MOZ_FFI_LIBS... -L/usr/lib/../lib -lffi
 1:05.41 checking for nodejs... /usr/bin/node: error while loading shared libraries: libicui18n.so.64: cannot open shared object file: No such file or directory
 1:05.41 no
 1:05.41 ERROR: NODEJS must point to node 8.11 or newer; found node location: /usr/bin/node.
 1:05.41     Executing `mach bootstrap --no-system-changes` should
 1:05.41     install a compatible version in ~/.mozbuild on most platforms.
 1:05.41     If you believe this is a bug, <https://mzl.la/2vLbXAv> is a good way
 1:05.41     to file.  More details: <https://bit.ly/2BbyD1E>
 1:05.53 *** Fix above errors and then restart with\
 1:05.53                "./mach build" 
 1:05.53 make: *** [client.mk:115: configure] Error 1
==> ERROR: A failure occurred in build().
    Aborting...

Am I reading that right? Upstream nodejs not yet rebuilt against the new ICU 65?

#13

Updated by oaken-source almost 2 years ago

your chroot is outdated, on my system node requires icu65

I'm currently rebuilding phantomjs, afterwards I can look at iceweasel and friends if need be :)

#14

Updated by freemor almost 2 years ago

Good catch I updated it late last night the nodejs stuf must have snuck in sing that.

Updating the Chroot and re-trying

#15

Updated by freemor almost 2 years ago

[libre/epiphany] X86_64 Rebuilt against new ICU. Updated to 3.35.1

#16

Updated by freemor almost 2 years ago

[libre/openttd] x86_64 rebuild against new ICU.

#17

Updated by freemor almost 2 years ago

[libre/calibre] x86_64 rebuilt against new icu

#18

Updated by freemor almost 2 years ago

2 of [pcr/california]'s patches are not available from the listed source. AUR only has California-git. Looks like California might need a Redux

#19

Updated by oaken-source almost 2 years ago

  • File california-0.4.0-libical-3.0.patch added
  • File 0002-Build-with-evolution-data-server-3.13.90.patch added

I have them archived locally. see attached.

#20

Updated by freemor almost 2 years ago

Excellent. Will grab them and do the rebuilds

#21

Updated by oaken-source almost 2 years ago

[pcr/phantomjs] patched and rebuilt for icu-65

#22

Updated by freemor almost 2 years ago

  • % Done changed from 20 to 40

think we are down to just the Ice* things. I'll be entering a busy all day type situation till Wed. or Thurs
So my ontibutions will definitely slow to a trickle for the next few days

#23

Updated by grizzlyuser almost 2 years ago

In case if it can help, here are patches for iceweasel 70.0 https://lists.parabola.nu/pipermail/dev/2019-October/007484.html . I didn't try to build it for i686 or armv7h though, only for x86_64. This still needs to be updated to include more recent commits from Arch firefox, starting from and including https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/firefox&id=bd92553bc3d37eb7667d9cdc349df89117a12687 .

#24

Updated by grizzlyuser almost 2 years ago

Tried to build iceweasel 70.0.1 with a few minor changes, it failed. Looks like because of recent rust update to 1.39.0.

#25

Updated by grizzlyuser almost 2 years ago

Successfully built iceweasel 70.0.1 for x86_64, but only after downgrading to rust 1.38.0-2. Not sure if upstream has patches to make it build with newer version.

#26

Updated by eliotime3000 almost 2 years ago

Actually, the Iceweasel language packs in the x86_64 version has been still into the version 69 (meanwhile the main package is into the version 70.0.1). The X86_32 and ARM releases of Icedove are still in the version 60.6.1, but the language packs for x86_32 and ARM are into the version 68.2.2.

#27

Updated by bill-auger over 1 year ago

#28

Updated by Anonymous over 1 year ago

Is it still WIP? Also there is #2614.

#30

Updated by bill-auger over 1 year ago

this is a recurring situation - there are probably dozens of tickets about either icu, poppler, texlive-bin, and cups-filters - sometimes they wont build for one of the arches and so the ticket gets left open

#31

Updated by Anonymous over 1 year ago

poppler conflicts with poppler-glib and poppler-qt5

#32

Updated by freemor over 1 year ago

libre/cups-filters and libre/texlive-bin now rebuilt for x86_64. new poppler not in arm/i686 yet.

#33

Updated by eliotime3000 over 1 year ago

Actually, the version 67 of ICU that arrived for x86_64 is generating conflicts with epiphany
, hardinfo, icecat, icedove and iceweasel.

resolviendo dependencias...
buscando conflictos entre paquetes...
error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: instalando icu (67.1-1) se rompe la dependencia con «icu<66», necesaria para el paquete epiphany
:: instalando icu (67.1-1) se rompe la dependencia con «icu<66», necesaria para el paquete hardinfo
:: instalando icu (67.1-1) se rompe la dependencia con «icu<66», necesaria para el paquete icecat
:: instalando icu (67.1-1) se rompe la dependencia con «icu<66», necesaria para el paquete icedove
:: instalando icu (67.1-1) se rompe la dependencia con «icu<66», necesaria para el paquete iceweasel
:: instalando icu (67.1-1) se rompe la dependencia con «icu<66», necesaria para el paquete texlive-bin

#34

Updated by bill-auger over 1 year ago

currently, this only affects x86_64 - arch32 and archarm have
not change 'icu' versions; and have no staging builds
_______________________________________

#35

Updated by bill-auger over 1 year ago

  • Status changed from confirmed to open
  • Subject changed from [icu 0.65.1][poppler 0.82.0] Conflicts - packages need rebuilds to [STICKY][poppler] and friends (x86_64)
  • Tracker changed from Bug to Housekeeping
#36

Updated by bill-auger over 1 year ago

#37

Updated by bill-auger over 1 year ago

  • Description updated (diff)
  • Subject changed from [STICKY][poppler] and friends (x86_64) to [STICKY][poppler]: and friends (x86_64)
#38

Updated by bill-auger over 1 year ago

  • File deleted (california-0.4.0-libical-3.0.patch)
#39

Updated by bill-auger over 1 year ago

  • File deleted (0002-Build-with-evolution-data-server-3.13.90.patch)
#40

Updated by bill-auger over 1 year ago

  • Related to Housekeeping #2351: [libre/cups-filters]: rebuild against new poppler (x86_64) added
#41

Updated by bill-auger over 1 year ago

  • Related to Housekeeping #2719: [pcr/frescobaldi]: rebuild against new poppler (x86_64) added
#42

Updated by bill-auger over 1 year ago

  • Description updated (diff)
#43

Updated by bill-auger over 1 year ago

  • Description updated (diff)
#44

Updated by bill-auger over 1 year ago

  • Description updated (diff)
#45

Updated by dllud 12 months ago

A new rebuild is needed:

installing poppler (20.10.0-1) breaks dependency 'poppler=20.09.0' required by cups-filters
installing poppler (20.10.0-1) breaks dependency 'poppler=20.09.0-1' required by texlive-bin

#46

Updated by dllud 10 months ago

Another rebuild is needed:

cannot resolve "poppler=20.12.0-1", a dependency of "texlive-bin"

Current version in Arch is 20.12.1-1

#47

Updated by bill-auger 10 months ago

dllud - thanks for the prompt alert - the new poppler was caught quickly this time - the dependent packages were rebuilt yesterday, without re-opening these rebuild tickets - the conflicts are resolved now

#48

Updated by dllud 9 months ago

icu's fault this time:

installing icu (68.2-1) breaks dependency 'libicui18n.so=67-64' required by texlive-bin
installing icu (68.2-1) breaks dependency 'libicuuc.so=67-64' required by texlive-bin

texlive-bin needs a rebuild.

#49

Updated by bill-auger 9 months ago

there is an analogous set of "STICKY" tickets for 'icu' dependents:

https://labs.parabola.nu/issues/2047

there is a 'icu-compat' package which resolves this sort of conflict for 'icu' dependents, without waiting for the package to be rebuilt - the 'poppler' dependents are not so simple though - those must be rebuilt ASAP - 'texlive-bin' is coincidentally on both rebuild lists

there is a recent BR re: 'texlive-bin' - becasue of the 'icu-compat' package, it is already essentially 'fixed'; but i left it open so that people could find it easily

https://labs.parabola.nu/issues/2950

#50

Updated by dllud 9 months ago

Heads up! :)
Now it's an actual poppler update breaking things:

installing poppler (21.01.0-1) breaks dependency 'poppler<20.12.2' required by cups-filters
installing poppler (21.01.0-1) breaks dependency 'poppler=20.12.1-1' required by texlive-bin

#51

Updated by eliotime3000 8 months ago

Actually, the version 21.02.0-1 of Poppler is generating the following package conflict

:: Sincronizando las bases de datos de los paquetes...
 libre está actualizado
 core está actualizado
 extra                1522,4 KiB  2030 KiB/s 00:01 [######################] 100%
 community               5,1 MiB  5,38 MiB/s 00:01 [######################] 100%
 pcr está actualizado
:: Iniciando actualización completa del sistema...
resolviendo dependencias...
buscando conflictos entre paquetes...
error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: instalando poppler (21.02.0-1) se rompe la dependencia con «poppler=21.01.0-1», necesaria para el paquete cups-filters
:: instalando poppler (21.02.0-1) se rompe la dependencia con «poppler=21.01.0-1», necesaria para el paquete texlive-bin

EDIT:

The following versions of cups-filters and texlive-bin needs to be updated to the following versions:
cups-filters: 1.28.7 >> https://archlinux.org/packages/extra/x86_64/cups-filters/
texlive-bin: 2020.54586-10 >> https://archlinux.org/packages/extra/x86_64/texlive-bin/

#52

Updated by eliotime3000 7 months ago

Today, I found that Poppler 21.03.0-1 had the same problem than almost one month ago.

:: Sincronizando las bases de datos de los paquetes...
 libre está actualizado
 core está actualizado
 extra está actualizado
 community está actualizado
 pcr está actualizado
:: Iniciando actualización completa del sistema...
resolviendo dependencias...
buscando conflictos entre paquetes...
error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: instalando poppler (21.03.0-1) se rompe la dependencia con «poppler=21.02.0-1», necesaria para el paquete cups-filters
:: instalando poppler (21.03.0-1) se rompe la dependencia con «poppler=21.02.0-1», necesaria para el paquete texlive-bin
#53

Updated by dllud 7 months ago

It's that time again:

installing poppler (21.03.0-1) breaks dependency 'poppler=21.02.0-1' required by cups-filters
installing poppler (21.03.0-1) breaks dependency 'poppler=21.02.0-1' required by texlive-bin

#54

Updated by bill-auger 7 months ago

only 3 weeks this time, too

#55

Updated by dllud 6 months ago

There we go again:

installing poppler (21.04.0-2) breaks dependency 'poppler=21.03.0-1' required by cups-filters
installing poppler (21.04.0-2) breaks dependency 'poppler=21.03.0-1' required by texlive-bin

As always, a big thanks for maintaining Parabola!

#56

Updated by eliotime3000 5 months ago

Actually, the packages texlive-bin and cups-filters one more time are affected by the Poppler update.

Here's the log:

:: instalando poppler (21.05.0-1) se rompe la dependencia con «poppler=21.04.0-2», necesaria para el paquete cups-filters
:: instalando poppler (21.05.0-1) se rompe la dependencia con «poppler=21.04.0-2», necesaria para el paquete texlive-bin

Thanks.

#57

Updated by bill-auger 5 months ago

thats what this ticket is for - thanks for noticing - the conflicts should be resolved now

#58

Updated by takuwan 4 months ago

cups-filters and texlive-bin need to be rebuilt again. They depend on poppler 21.06.0, but the latest version in the repos is 21.06.1:

:: Starting full system upgrade...
resolving dependencies...
warning: cannot resolve "poppler=21.06.0-1", a dependency of "cups-filters" 
warning: cannot resolve "poppler=21.06.0-1", a dependency of "texlive-bin" 
:: The following packages cannot be upgraded due to unresolvable dependencies:
      cups-filters  texlive-bin

:: Do you want to skip the above packages for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'poppler=21.06.0-1' required by cups-filters
:: unable to satisfy dependency 'poppler=21.06.0-1' required by texlive-bin
#59

Updated by biovoid 3 months ago

And we're back:

:: installing poppler (21.07.0-1) breaks dependency 'poppler=21.06.1-1' required by cups-filters
#60

Updated by eliotime3000 3 months ago

:: instalando poppler (21.07.0-1) se rompe la dependencia con «poppler=21.06.1-1», necesaria para el paquete texlive-bin

There's a dependence conflict with texlive-bin with the latest upgrade of Poppler package.

#61

Updated by bill-auger 3 months ago

fixed

#62

Updated by pavelsayekat about 2 months ago

pacman -Syu
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing poppler (21.07.0-2) breaks dependency 'poppler=21.07.0-1' required by cups-filters
:: installing poppler (21.07.0-2) breaks dependency 'poppler=21.07.0-1' required by texlive-bin

#63

Updated by bill-auger about 2 months ago

fixed

#64

Updated by eliotime3000 about 2 months ago

texlive-bin package has been having some issue dependencies during package udpate.

:: Sincronizando las bases de datos de los paquetes...
 libre está actualizado
 core está actualizado
 extra está actualizado
 community está actualizado
 pcr está actualizado
:: Iniciando actualización completa del sistema...
resolviendo dependencias...
buscando conflictos entre paquetes...
error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
:: instalando poppler (21.08.0-1) se rompe la dependencia con «poppler=21.07.0-3», necesaria para el paquete texlive-bin
#65

Updated by bill-auger about 2 months ago

  • Related to Bug #3075: [cups-filters][texlive-bin]: installing poppler (N) breaks dependency added
#66

Updated by takuwan 17 days ago

poppler 21.09.0-1 breaks texlive-bin

:: Synchronizing package databases...
 nonprism is up to date
 libre                                                                     314.2 KiB   714 KiB/s 00:00 [#############################################################] 100%
 core                                                                      121.9 KiB   271 KiB/s 00:00 [#############################################################] 100%
 extra                                                                    1447.4 KiB  2.83 MiB/s 00:01 [#############################################################] 100%
 community                                                                   5.4 MiB  3.72 MiB/s 00:01 [#############################################################] 100%
 pcr is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing poppler (21.09.0-1) breaks dependency 'poppler=21.08.0-1' required by texlive-bin

Also available in: Atom PDF