Project

General

Profile

Linux-libre-lts no wifi and bluetooth !

SveniD85 - over 1 year ago -

Hello everybody, i am new here and in the linux world.

Since the last systemupdate with the linux-libre-lts upgrade to 5.4.85 i saw today that i have no internet and bluetooth connection !

I booted the live iso and the pacman -Syuu command does not work. I have no connections !

I have an original fujitsu lifebook a530 with an atheros wifi chip -> AR9285 and use the Parabola GNU / Linux with systemd !

Greetings from germany and sorry for my english.


Replies (17)

RE: Linux-libre-lts no wifi and bluetooth ! - Phosit - over 1 year ago -

Hello SveniD85
Are the driver running?
You can detect it by running:

lsusb -t

or for pci:
lspci -k

ps. Ich finde dein Englisch nicht schlecht ;)

RE: Linux-libre-lts no wifi and bluetooth ! - SveniD85 - over 1 year ago -

Hello Phosit, thank you very much for your reaction.

My laptop tell me that the kernel has the ath9k driver in use !

I installed parabola new after i switched to arch because i needed the world wide web. I had no problems to install parabola again with my setup routine and wifi but after this i had the same problems !
I have the connected wifi icon and the % status ( Signalstärke ) but nothing works. Pacman, the browser, the weather plugin, nothing works !

All what works and this was my mistake is my bluetooth headset because i forgotten to reset him after reinstall !

Vielen Dank für die Antwort. MfG

RE: Linux-libre-lts no wifi and bluetooth ! - Phosit - over 1 year ago -

I don't think the kernel(linux-libre-lts) is the problem.
Are you able to ping a server? Try:

ping gnu.org
ping 209.51.188.148

RE: Linux-libre-lts no wifi and bluetooth ! - SveniD85 - over 1 year ago -

No, does not work !

I get an error message -> temporaly mistake with name... ( Temporärer Fehler bei der Namensauflösung ) !

I can only say that i have the problems since the last linux-libre-lts update ! Arch worked without problem and the installation with the parabola iso worked without problems !

RE: Linux-libre-lts no wifi and bluetooth ! - Phosit - over 1 year ago -

"ping 209.51.188.148" shouldn't need name resolution. Probabli the name translation(NAT) on your router fails...
Are you able to ping your Router moast propably:

ping 192.168.1.1

Do you even have an ip address? whats the output of

ip a

RE: Linux-libre-lts no wifi and bluetooth ! - SveniD85 - over 1 year ago -

Yes, with ip a i see my ip address and with ping -c 3 i get three successfully answers after 0.04 ms for one !

RE: Linux-libre-lts no wifi and bluetooth ! - Phosit - over 1 year ago -

Now i'm "out of knowledge".
Possibly linux-libre-lts 5.4.85 devaults to ipv6 and your router/isp dosn't provide it...

Sory that i can't help.

RE: Linux-libre-lts no wifi and bluetooth ! - freemor - over 1 year ago -

Could be that there is no default gateway set I.E. no route to outside networks definied.

Use the commands:

ip route

or

route

and make sure that "default" is pointed to the ip address of your router

This often happens when people assign a static IP address and forget that they need to define toe routes also.

RE: Linux-libre-lts no wifi and bluetooth ! - SveniD85 - over 1 year ago -

The ip route command shows me following :

default via 192.xxx.xxx.1 dev wlp3s0 proto dhcp metric 20600

192.xxx.xxx.0/24 dev wlp3s0 proto kernel scope link source 192.xxx.xxx.1xx.151 metric 600

! ! !

RE: Linux-libre-lts no wifi and bluetooth ! - bill-auger - over 1 year ago -

if you are running the i686 port, there is a problem with DHCP
and IP4

RE: Linux-libre-lts no wifi and bluetooth ! - SveniD85 - over 1 year ago -

But all other works. I had no problems with arch linux and i had no problems at the parabola installation with wifi connection. Only the ready OS since 5.4.85 lts kernel make this problem !

Wenn sich die nächsten Tage nix tut gebe ich es auf & wechsel dauerhaft zu arch linux ! Wäre zwar schade da ich gerne nach meinem radikalen Umstieg von Windows mit einem Betriebssystem wie diesem mit gänzlich freier Software das weitere Leben verbringen wollte aber mittlerweile habe ich die schnauze gestrichen voll ! Ich war nach vielen belesen & Videos schauen so Glücklich das mein Notebook auf h-node als A-Platinum gelistet war doch bei der Installation war es auch schon fast vorbei ! Die Desktop-Iso's funktionierten gar nicht ( bzw. ich eingach zu doof dafür bin ) obwohl ich es geschafft hatte mich bei der Systemd-version über hidden connections mit dem Internet zu verbinden. Ich hatte auch alles im Installer ordentlich ausgefüllt ( Kleinschreibweise & keine Leerzeichen ) & trotzdem kein Systemstart erlebt !
Über die Befehlszeile hatte ich es dann endlich geschafft mit dem OpenRC-iso ein Systemd Parabola zu installieren. Da hatte ich Glück das ich noch DOS kennenlernen durfte & eine super Lehrerin hatte & das ich einen sehr guten Youtuber gefunden hatte mit dessen Videos ich mir eine funktionstüchtige Installationsanleitung zusammenbasteln konnte ! Wenn das dann alles für'n Ar**h war....naja.

Trotzdem vielen lieben Dank für die Hilfe.
Mit freundlichen Grüßen

RE: Linux-libre-lts no wifi and bluetooth ! - freemor - over 1 year ago -

The fact that you have an IP, have routes set (presumably via DHCP), and can ping the router means that your wifi card IS working.
so it is not a kernel module issue.

if you have extra/mtr installed or can get it installed by chrooting then you could run:

mtr 209.51.188.148

You could also try:

tracepath -n 209.51.188.148

as tracepath may already be installed, but I find it slow and prone to getting stuck on "No Reply" hosts rather then contimuing to the destination.

These will let you see if your traffic is traveling out of your network. mtr is very good at showing where the path dead ends if there is some error keeping things from getting to the final destination. tracepath unfortunately gets stuck too often to be much help in that regard but will let you see if things are getting out.

also what does:

cat /etc/resolv.conf

show in case its a DNS issue. When you tried the ping commads from that earlier post did you try with both the name and the bare IP address?

You'll not be able to use the internet hardly at all if your DNS is not working

RE: Linux-libre-lts no wifi and bluetooth ! - freemor - over 1 year ago -

BTW you do not need to worry about sharing full 192.168.x.x IP addresses they are a class of LAN only ip addresses and as such not routable over the Internet.

In lay persons terms they are "inside" IP addresses not reachable over the Internet only over the LAN. Your router should be translating those (via NAT) to your "outside" actual ISP provided IP address.

NAT allows you to have 1 real IP address which is then shared by many devices behind the router by giving the "inside" devices a 192.168.x.x address and then translating on the fly to the outside IP when talking to the Internet.

If someone wanted to connect to you they would require the Internet routable "outside" WAN IP

RE: Linux-libre-lts no wifi and bluetooth ! - SveniD85 - over 1 year ago -

Hello everybody

Today i formated my hdd and installed a minimum parabola because i got ssl certificates error messages in live iso chroot !

In the Installationroutine i had no problems, wifi connection worked fine but after the first systemstart i had the same problems !

The following list shows the important steps which i did after formated and mounted my hdd / partitions :

nmtui connect -> no problem

ip a -> 192.168.178.151/24

pacman - Sy archlinux-keyring archlinuxarm-keyring parabola-keyring

pacman - U https://www.parabola.nu/packages/core/i686/archlinux32-keyring-transition/download/
-> remove archlinux32-keyring

pacstrap /mnt base base-devel linux-libre-lts linux-libre-firmware grub os-prober bash-completion netctl dialog wpa_supplicant networkmanager network-manager-applet nm-connection-editor lightdm lightdm-gtk-greeter ntfs-3g dosfstools mtools p7zip acpid cronie mtr

arch-chroot /mnt

locale conf and gen -> de_DE.UTF-8 and de_DE

ln -sf /usr/share/zoneinfo/Europe/Berlin /etc/localtime

useradd -m -g users -G wheel -s /bin/bash sven

EDITOR=nano visudo -> activate %wheel

systemctl enable acpid avahi-daemon cronie lightdm NetworkManager systemd-timesyncd.service

date -> hwclock -w -> all correct

pacman -S xorg-server xorg-xinit xf86-video-intel

pacman -S xfce4 xfce4-goodies (all, all, extra)

exit -> umount -R /mnt -> exit -> reboot

In the ready OS ===============

I connected with wifi and got the "connected" icon. pacman -Syu does not work -> only error with names !

lspci -k says that the ath9 driver is in use !

ip a -> 192.168.178.151/24

ping -c 3 gnu.org -> temporary mistakes with name

ping -c 209.51.188.148 works -> ( 280 , 279 , 314 ms )

myself ping -c 3 192.168.178.1 works ( 1.81 , 1.64 , 1.61 ms )

ip route
default via 192.168.178.1 dev wlp3s0 proto dhcp metric 20600
192.168.178.0/24 dev wlp3s0 proto kernel scope link src 192.168.178.151 metric 600

mtr 209.51.188.148 does not shows an error

I have 5 times 129.250.x -> the searchengine says that is an ntt server in texas , united states !

nano /etc/resolv.conf has two #-info lines and that was it, there is nothing in !

Thank you very much for help

RE: Linux-libre-lts no wifi and bluetooth ! - freemor - over 1 year ago -

Thanks for the info and effort.. And now we know the problem.. no DNS resolvers set. We just do not know why yet.

You can fix it temporarily by editing /etc/resolv.conf and adding a couple "nameserver <ip address>" lines

usually your main router acts as a DNS resolver so adding:

nameserver <ip address of your router>

you can add multiple nameserver lines. So if you have another DNS resolver you want to add just put its IP address on a seperate namserver line

which would look like:

nameserver <ip of your router>
nameserver x.x.x.x
nameserver y.y.y.y

then save the file and you should be able to ping gnu.org by name
and have a working internet

So we need to figure out why DHCP isn't picking up your DNS resolvers.

But try the above first.. It should get you going.

RE: Linux-libre-lts no wifi and bluetooth ! - SveniD85 - over 1 year ago -

I could @₩#£&😤😭*¿♧~ ! Why the OS takes an stupid guy like me which say f u microsoft , i want live with you free software universe :''-(((

But now it works again :-)

I have many to learn about the OS !

Thank you sooo very much for the help :-*

    (1-17/17)