Project

General

Profile

Bug #3367

[multiple]: signature from "bill-auger <bill-auger@peers.community>" is unknown trust corrupted (invalid or corrupted package (PGP signature)

eliotime3000 - 30 days ago - . Updated 26 days ago.

Status:
in progress
Priority:
bug
Assignee:
% Done:

0%


Description

The version 20220719-1 of your-freedom package seems to have a PGP signature conflict, which avoids to update the whole system.

The result that shows in the sudo pacman -Syu log is the following:

:: ¿Continuar con la instalación? [S/n] s
:: Obteniendo los paquetes...
 your-freedom-202...    19,2 KiB  9,40 KiB/s 00:02 [######################] 100%
(56/56) comprobando las claves del depósito        [######################] 100%
(56/56) verificando la integridad de los paquetes  [######################] 100%
error: your-freedom: se desconoce el nivel de confianza de la firma de «bill-auger <bill-auger@peers.community>»
:: El archivo /var/cache/pacman/pkg/your-freedom-20220719-1-any.pkg.tar.zst está dañado (paquete no válido o dañado (firma PGP)).
¿Quiere eliminarlo? [S/n] 

I want to know if this package would be needed to be updated in order to update the whole Parabola system.

Thanks.

History

#1

Updated by Mampir 28 days ago

I can confirm that installing packages gives the most common Parabola error:

error: parabola-keyring: signature from "bill-auger <bill-auger@peers.community>" is unknown trust
:: File /var/cache/pacman/pkg/parabola-keyring-20221019-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).

Unfortunately it seems like this issue will never be really fixed, because as I understand Bill Auger thinks this is not a problem, even when everyone encounters this error on a regular basis.

#2

Updated by gap 28 days ago

In my experience you have to upgrade the various keyring packages before doing the full system upgrade.

#3

Updated by Mampir 27 days ago

gap wrote:

In my experience you have to upgrade the various keyring packages before doing the full system upgrade.

Unfortunately this workaround doesn't work all the time, including in the current case. You can see I am trying to upgrade the parabola-keyring package.

#4

Updated by Mampir 27 days ago

You can try doing:

# pacman-key --refresh-keys bill-auger@peers.community
#5

Updated by bill-auger 26 days ago

  • Assignee set to bill-auger
  • Status changed from unconfirmed to in progress
  • Subject changed from [your-freedom] Invalid PGP signature to [multiple]: signature from "bill-auger <bill-auger@peers.community>" is unknown trust corrupted (invalid or corrupted package (PGP signature)
#6

Updated by bill-auger 26 days ago

parabola-keyring 20221105-1 fixes this

# pacman -Sy parabola-keyring && pacman -Su

Also available in: Atom PDF