Project

General

Profile

Housekeeping #3421

[STICKY][qt5-base]: and friends (x86_64)

bill-auger - about 1 year ago - . Updated 5 months ago.

Status:
open
Priority:
bug
Assignee:
-
% Done:

100%


Description

this is the current list of 'qt5-base' dependents for x86_64 systems - each time 'qt5-base' is upgraded in arch, each of these packages should be rebuilt against the upgraded 'qt5-base', pinned to 'qt5-base=N.N.N'

# build order: (qt5-base) <- qt5-styleplugins
#              (qt5-base) <- qt5-webkit <- python-pyqt5 <- qutebrowser

Subtasks

Bug #2584: [qutebrowser]: rebuild against latest qt5-base (x86_64)fixedbill-auger

Actions
Bug #3008: [libre/qt5-styleplugins]: rebuild against latest qt5-base (x86_64)fixedbill-auger

Actions
Bug #3419: [python-pyqt5]: rebuild against latest qt5-base (x86_64)fixedbill-auger

Actions
Bug #3420: [qt5-webkit]: rebuild against latest qt5-base (x86_64)fixedbill-auger

Actions

History

#1

Updated by bill-auger about 1 year ago

NOTE: quassel may also need to be added to this list - it is pinned to qt5-base via qt5-webkit; but that does not ensure that it will work with the upgraded qt5-base

#2

Updated by bill-auger about 1 year ago

  • Description updated (diff)
#3

Updated by bill-auger about 1 year ago

  • Description updated (diff)
#4

Updated by dllud 5 months ago

Hi,

qt5-base was upgraded to 5.15.11, a new rebuild is needed:

:: installing qt5-base (5.15.11+kde+r134-1) breaks dependency 'qt5-base<5.15.11' required by python-pyqt5
:: installing qt5-base (5.15.11+kde+r134-1) breaks dependency 'qt5-base<5.15.11' required by qt5-styleplugins
:: installing qt5-base (5.15.11+kde+r134-1) breaks dependency 'qt5-base<5.15.11' required by qt5-webkit

Thanks!

Also available in: Atom PDF